We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Ubuntu Mirrors


ned14
09-03-2009, 09:54 AM

If you append the proper Ubuntu mirrors after the OVH ones, it will use
OVH when it can and the Ubuntu ones when necessary.

I would strongly suggest that OVH make this the default.

Cheers,
Niall


--
ned14
------------------------------------------------------------------------
ned14's Profile: http://forum.ovh.ie/member.php?userid=6
View this thread: http://forum.ovh.ie/showthread.php?t=28


eoghan
09-03-2009, 09:54 AM

The OVH ubuntu mirror is painfully out of date. Trying to install the
vim package, for example, results in:



Code:
--------------------
# apt-get install vim
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
vim: Depends: vim-common (= 2:7.2.025-2ubuntu1) but 2:7.2.079-1ubuntu5 is to be installed
Depends: vim-runtime (= 2:7.2.025-2ubuntu1) but 2:7.2.079-1ubuntu5 is to be installed
E: Broken packages

--------------------


... and the same for python-setuptools:


Code:
--------------------
# apt-get install python-setuptools
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
python-setuptools: Depends: python (>= 2.4) but it is not going to be installed
Depends: python (< 2.6) but it is not going to be installed
Depends: python-central (>= 0.5.7) but it is not going to be installed
Depends: python-pkg-resources (= 0.6c9-0ubuntu1) but it is not going to be installed
E: Broken packages

--------------------


From a little bit of snooping around, it looks like packages in the
jaunty ovh repository are actually from the ubuntu intrepid repository.


Information for the (intrepid) python-setuptools package on
http://tinyurl.com/oy4zzk:


Code:
--------------------
Exact Size 192202 Byte (187.7 kByte)
MD5 checksum 5eb44c91cce38e8a7b5fbbc0ae344348
SHA1 checksum beb9456d0901a0ba67410a9eaaa6caa2ecb19b4a
SHA256 checksum 30e665f6d1b53b830f906738df41a515d4beecd0229711d2f7 340e50be8cb2e2
--------------------


... and from the package in the ovh (jaunty) repository:


Code:
--------------------
Filename: pool/main/p/python-setuptools/python-setuptools_0.6c9-0ubuntu1_all.deb
Size: 192202
MD5sum: 5eb44c91cce38e8a7b5fbbc0ae344348
SHA1: beb9456d0901a0ba67410a9eaaa6caa2ecb19b4a
SHA256: 30e665f6d1b53b830f906738df41a515d4beecd0229711d2f7 340e50be8cb2e2

--------------------


Some packages work fine, but this is happening a lot.

I've given up on using the ovh mirrors for now, 'cos they're
practically unusable.


--
eoghan
------------------------------------------------------------------------
eoghan's Profile: http://forum.ovh.ie/member.php?userid=72
View this thread: http://forum.ovh.ie/showthread.php?t=28